import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\S+\\s+){6}(\\d+)";
final String string = "080323 1051 0004 7 9 888 89818888888 140 7 010 4\n"
+ "080323 1052 0002 9 888 6999 989818888888 7 001 0\n"
+ "080323 1052 0002 9 888 140 989818888888 7 001 0\n"
+ "080323 1349 0003 A 9 888 89517777777 178 3 029 4\n"
+ "080323 1447 0000 A 9 888 89517777777 178 3 007 4\n"
+ "080323 1448 0003 A 9 888 89517777777 178 3 008 4\n"
+ "080323 1925 0000 9 888 524 989217777777 7 002 0\n"
+ "080323 1925 0000 7 888 5651 524 7 003 4\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}