import Foundation
let pattern = #"^(?:\S+\s+){6}(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
080323 1051 0004 7 9 888 89818888888 140 7 010 4
080323 1052 0002 9 888 6999 989818888888 7 001 0
080323 1052 0002 9 888 140 989818888888 7 001 0
080323 1349 0003 A 9 888 89517777777 178 3 029 4
080323 1447 0000 A 9 888 89517777777 178 3 007 4
080323 1448 0003 A 9 888 89517777777 178 3 008 4
080323 1925 0000 9 888 524 989217777777 7 002 0
080323 1925 0000 7 888 5651 524 7 003 4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)