#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^|\s)#(\w+)"
Local $sString = "#gethashtagsregexp" & @CRLF & _
"" & @CRLF & _
"$1. Blank Space" & @CRLF & _
"$2. Hashtag content #:content"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")