const regex = /(^|\s)#(\w+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s)#(\\w+)', '')
const str = `#gethashtagsregexp
\$1. Blank Space
\$2. Hashtag content #:content`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}