import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^#[a-f0-9]{6}(?:,\\s*#[a-f0-9]{6})?$";
final String string = "rgb(255,0,24)\n"
+ "rgb(255, 0, 24)\n"
+ "rgba(255, 0, 24, .5)\n"
+ "hsla(170, 23%, 25%, 0.2 )\n"
+ "#fff\n"
+ "#f2ewq\n"
+ "#0f243e\n"
+ "#0f243e,#3f54ae\n"
+ "#0f243eпп\n"
+ "#0f243eбб,#3f54aeпп\n"
+ "0x00ffff\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}