const regex = /^#[a-f0-9]{6}(?:,\s*#[a-f0-9]{6})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^#[a-f0-9]{6}(?:,\\s*#[a-f0-9]{6})?$', 'gm')
const str = `rgb(255,0,24)
rgb(255, 0, 24)
rgba(255, 0, 24, .5)
hsla(170, 23%, 25%, 0.2 )
#fff
#f2ewq
#0f243e
#0f243e,#3f54ae
#0f243eпп
#0f243eбб,#3f54aeпп
0x00ffff
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}