# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^#[a-f0-9]{6}(?:,\s*#[a-f0-9]{6})?$"
test_str = ("rgb(255,0,24)\n"
"rgb(255, 0, 24)\n"
"rgba(255, 0, 24, .5)\n"
"hsla(170, 23%, 25%, 0.2 )\n"
"#fff\n"
"#f2ewq\n"
"#0f243e\n"
"#0f243e,#3f54ae\n"
"#0f243eпп\n"
"#0f243eбб,#3f54aeпп\n"
"0x00ffff\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.