using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\[[\w*\s?]*-?\s?[\w*]*\s?[\d*]*?]*$";
string input = @"\Diageo_Catalogues\CATALOGUES_SEPTEMBER_2015\test for WE\Haig Club - asdf";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}