re = /\\[[\w*\s?]*-?\s?[\w*]*\s?[\d*]*?]*$/
str = '\\Diageo_Catalogues\\CATALOGUES_SEPTEMBER_2015\\test for WE\\Haig Club - asdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end