$re = '/\\\\[[\w*\s?]*-?\s?[\w*]*\s?[\d*]*?]*$/';
$str = '\\Diageo_Catalogues\\CATALOGUES_SEPTEMBER_2015\\test for WE\\Haig Club - asdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);