package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\\[[\w*\s?]*-?\s?[\w*]*\s?[\d*]*?]*$`)
var str = `\Diageo_Catalogues\CATALOGUES_SEPTEMBER_2015\test for WE\Haig Club - asdf`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}