const regex = /^[^\pL\pN\n]*(?:\pN+[^\pL\n]*\pL|\pL+[^\d\n]*\pN).*/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\pL\\pN\\n]*(?:\\pN+[^\\pL\\n]*\\pL|\\pL+[^\\d\\n]*\\pN).*', 'gmu')
const str = `aaaaaaaa
11111111
@!@!@^%a
@!@!@^%1
@@@@1@@@@a@@@@`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}