// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)^[^\pL\pN\n]*(?:\pN+[^\pL\n]*\pL|\pL+[^\d\n]*\pN).*").unwrap();
let string = "aaaaaaaa
11111111
@!@!@^%a
@!@!@^%1
@@@@1@@@@a@@@@";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}