re = /^[^\pL\pN\n]*(?:\pN+[^\pL\n]*\pL|\pL+[^\d\n]*\pN).*/m
str = 'aaaaaaaa
11111111
@!@!@^%a
@!@!@^%1
@@@@1@@@@a@@@@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end