$re = '/^[^\pL\pN\n]*(?:\pN+[^\pL\n]*\pL|\pL+[^\d\n]*\pN).*/mu';
$str = 'aaaaaaaa
11111111
@!@!@^%a
@!@!@^%1
@@@@1@@@@a@@@@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);