#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^FT_)(FMS|LOC|MFG|SRM|CRM|HCM|SOE)(_)([a-zA-Z0-9]+(_))*([a-zA-Z0-9]+)$"
Local $sString = "FT_FMS_HJASGDJAG312_ZZZZZ_XDCDCfdghfh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")