// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^FT_)(FMS|LOC|MFG|SRM|CRM|HCM|SOE)(_)([a-zA-Z0-9]+(_))*([a-zA-Z0-9]+)$").unwrap();
let string = "FT_FMS_HJASGDJAG312_ZZZZZ_XDCDCfdghfh";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}