using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^FT_)(FMS|LOC|MFG|SRM|CRM|HCM|SOE)(_)([a-zA-Z0-9]+(_))*([a-zA-Z0-9]+)$";
string input = @"FT_FMS_HJASGDJAG312_ZZZZZ_XDCDCfdghfh";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}