const regex = /(<p[^>]+")([^>"]+)/gmiu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<p[^>]+")([^>"]+)', 'gmiu')
const str = `<p id="tem" style="text-align: justify;"><span style="font-size: 11pt;">hello world<br /></span></p>
<p style="text-align: justify;">test</p>
<p > </p>
<p> </p>`;
const subst = `$1$2margin:0;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);