use strict;
my $str = 'this is a "text field" need "to replace"';
my $regex = qr/"[^"]*"|\S+/mp;
my $subst = '+$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";