import Foundation
let pattern = #""[^"]*"|\S+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"this is a "text field" need "to replace""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"+$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)