$re = '/"[^"]*"|\S+/m';
$str = 'this is a "text field" need "to replace"';
$subst = "+$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;