using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w*\$)[\s]*(\/[\w]*)[\s]*([\w ]*)\n\s*([\w\\]*)[\s\/]*([\w ]*)\n\s*([\s\^\(\w\\\$\)\[\]\*\/\-\?\:]*)^(\w*\$)\s*([\w\/\-]*)\s*([\w \-\/]*)[\n\s]*([\w\/\-\\]*)[\s\/]*([\w ]*)\n\s*([\w\/\-\\]*)[\s\/]*([\w\/\-\\ ]*)\s*(\w*)";
string input = @"
Name Mount Point Description
---- ----------- -----------
C$ / Remote Administration
ETC$ /etc Remote Administration
BUILTIN\Administrators / Full Control
C$ / Remote Administration
BUILTIN\Administrators / Full Control
HYDROQC\APPL-NETAPP-ADMIN / Full Control
^(ETC\$)[\s]*(\/[\w]*)[\s]*([a-zA-Z\s]*)\n\s*([\w\\]*)[\s\/]*([a-zA-Z\s]*)\n^(C\$)[\s]*(\/[\w]*)[\s]*([\w\s]*)\n(?:\s*([\w\\]*)[\s\/]*([a-zA-Z\s]*)\n)
([\s\^\(\w\\\$\)\[\]\*\/\-\?\:]*)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}