re = /^(\w*\$)[\s]*(\/[\w]*)[\s]*([\w ]*)\n\s*([\w\\]*)[\s\/]*([\w ]*)\n\s*([\s\^\(\w\\\$\)\[\]\*\/\-\?\:]*)^(\w*\$)\s*([\w\/\-]*)\s*([\w \-\/]*)[\n\s]*([\w\/\-\\]*)[\s\/]*([\w ]*)\n\s*([\w\/\-\\]*)[\s\/]*([\w\/\-\\ ]*)\s*(\w*)/mi
str = '
Name Mount Point Description
---- ----------- -----------
C$ / Remote Administration
ETC$ /etc Remote Administration
BUILTIN\\Administrators / Full Control
C$ / Remote Administration
BUILTIN\\Administrators / Full Control
HYDROQC\\APPL-NETAPP-ADMIN / Full Control
^(ETC\\$)[\\s]*(\\/[\\w]*)[\\s]*([a-zA-Z\\s]*)\\n\\s*([\\w\\\\]*)[\\s\\/]*([a-zA-Z\\s]*)\\n^(C\\$)[\\s]*(\\/[\\w]*)[\\s]*([\\w\\s]*)\\n(?:\\s*([\\w\\\\]*)[\\s\\/]*([a-zA-Z\\s]*)\\n)
([\\s\\^\\(\\w\\\\\\$\\)\\[\\]\\*\\/\\-\\?\\:]*)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end