import Foundation
let pattern = #"^(\w*\$)[\s]*(\/[\w]*)[\s]*([\w ]*)\n\s*([\w\\]*)[\s\/]*([\w ]*)\n\s*([\s\^\(\w\\\$\)\[\]\*\/\-\?\:]*)^(\w*\$)\s*([\w\/\-]*)\s*([\w \-\/]*)[\n\s]*([\w\/\-\\]*)[\s\/]*([\w ]*)\n\s*([\w\/\-\\]*)[\s\/]*([\w\/\-\\ ]*)\s*(\w*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Name Mount Point Description
---- ----------- -----------
C$ / Remote Administration
ETC$ /etc Remote Administration
BUILTIN\Administrators / Full Control
C$ / Remote Administration
BUILTIN\Administrators / Full Control
HYDROQC\APPL-NETAPP-ADMIN / Full Control
^(ETC\$)[\s]*(\/[\w]*)[\s]*([a-zA-Z\s]*)\n\s*([\w\\]*)[\s\/]*([a-zA-Z\s]*)\n^(C\$)[\s]*(\/[\w]*)[\s]*([\w\s]*)\n(?:\s*([\w\\]*)[\s\/]*([a-zA-Z\s]*)\n)
([\s\^\(\w\\\$\)\[\]\*\/\-\?\:]*)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)