import re
regex = re.compile(r"^(\w*\$)[\s]*(\/[\w]*)[\s]*([\w ]*)\n\s*([\w\\]*)[\s\/]*([\w ]*)\n\s*([\s\^\(\w\\\$\)\[\]\*\/\-\?\:]*)^(\w*\$)\s*([\w\/\-]*)\s*([\w \-\/]*)[\n\s]*([\w\/\-\\]*)[\s\/]*([\w ]*)\n\s*([\w\/\-\\]*)[\s\/]*([\w\/\-\\ ]*)\s*(\w*)", flags=re.MULTILINE | re.IGNORECASE)
test_str = (" \n"
" \n"
"Name Mount Point Description\n"
"---- ----------- -----------\n"
"C$ / Remote Administration\n"
"ETC$ /etc Remote Administration\n"
" BUILTIN\\Administrators / Full Control\n"
"C$ / Remote Administration\n"
" BUILTIN\\Administrators / Full Control\n"
" HYDROQC\\APPL-NETAPP-ADMIN / Full Control\n\n\n\n\n\n\n\n\n\n"
"^(ETC\\$)[\\s]*(\\/[\\w]*)[\\s]*([a-zA-Z\\s]*)\\n\\s*([\\w\\\\]*)[\\s\\/]*([a-zA-Z\\s]*)\\n^(C\\$)[\\s]*(\\/[\\w]*)[\\s]*([\\w\\s]*)\\n(?:\\s*([\\w\\\\]*)[\\s\\/]*([a-zA-Z\\s]*)\\n)\n\n"
"([\\s\\^\\(\\w\\\\\\$\\)\\[\\]\\*\\/\\-\\?\\:]*)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")