const regex = /AA(?!A)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('AA(?!A)', 'g')
const str = `bbbAAAAC1AAAAAAAA AAA AAAAArrr`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);