use strict;
my $str = 'bbbAAAAC1AAAAAAAA AAA AAAAArrr';
my $regex = qr/AA(?!A)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";