$re = '/AA(?!A)/';
$str = 'bbbAAAAC1AAAAAAAA AAA AAAAArrr';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;