import Foundation
let pattern = #"AA(?!A)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"bbbAAAAC1AAAAAAAA AAA AAAAArrr"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)