using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([^ .]+ )*\S*\.\S+)";
string input = @"file1.txt .project file2.jpg tricky file name.txt other tricky filenames containing áéÃőéáóó.gif";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}