re = /(([^ .]+ )*\S*\.\S+)/
str = 'file1.txt .project file2.jpg tricky file name.txt other tricky filenames containing áéÃőéáóó.gif'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end