package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^.*(?<ID>[0-9]{1,})-(?<Dummy>[0-9]{1,})(?<Number>\.[0-9]*)?\.pst$`)
var str = `Evolve-Body PO-BPOVendorStatus.4-0.5.pst`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}