$re = '/^.*(?<ID>[0-9]{1,})-(?<Dummy>[0-9]{1,})(?<Number>\.[0-9]*)?\.pst$/im';
$str = 'Evolve-Body PO-BPOVendorStatus.4-0.5.pst';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);