import re
regex = re.compile(r"^.*(?<ID>[0-9]{1,})-(?<Dummy>[0-9]{1,})(?<Number>\.[0-9]*)?\.pst$", flags=re.IGNORECASE | re.MULTILINE)
test_str = "Evolve-Body PO-BPOVendorStatus.4-0.5.pst"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")