use strict;
my $str = 'Evolve-Body PO-BPOVendorStatus.4-0.5.pst';
my $regex = qr/^.*(?<ID>[0-9]{1,})-(?<Dummy>[0-9]{1,})(?<Number>\.[0-9]*)?\.pst$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}