re = /\\[a-zA-Z\h]+\\/m
str = 'WORK ORDERS\\Subdivision Subdivision\\Sec. 64\\72751401_123 street dr.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end