// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\[a-zA-Z\h]+\\").unwrap();
let string = "WORK ORDERS\\Subdivision Subdivision\\Sec. 64\\72751401_123 street dr.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}