package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<cond>\{(\$|if|foreach).+\})(.|\n)?(\{end\k<cond>|)`)
var str = `{if $var == 0}
text
{endif}
{foreach $array as $key => $val}
{if $var == 1}{endif}
{endforeach}
{$var}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}