import re
regex = re.compile(r"(?<cond>\{(\$|if|foreach).+\})(.|\n)?(\{end\k<cond>|)", flags=re.MULTILINE)
test_str = ("{if $var == 0}\n"
"text\n"
"{endif}\n\n"
"{foreach $array as $key => $val}\n"
" {if $var == 1}{endif}\n"
"{endforeach}\n\n"
"{$var}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")