const regex = /(?<cond>\{(\$|if|foreach).+\})(.|\n)?(\{end\k<cond>|)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<cond>\\{(\\$|if|foreach).+\\})(.|\\n)?(\\{end\\k<cond>|)', 'gm')
const str = `{if \$var == 0}
text
{endif}
{foreach \$array as \$key => \$val}
{if \$var == 1}{endif}
{endforeach}
{\$var}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}