#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^/]+/([0-9 ]+).{2}"
Local $sString = "2asd 100 ps" & @CRLF & _
"100 / 100 PS" & @CRLF & _
"100 / 100 HP" & @CRLF & _
"100 / 1s0 HP" & @CRLF & _
"100 /10S hp" & @CRLF & _
"100/10S HP" & @CRLF & _
"100/10SHP" & @CRLF & _
"100/10SPS" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")