import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^/]+/([0-9 ]+).{2}";
final String string = "2asd 100 ps\n"
+ "100 / 100 PS\n"
+ "100 / 100 HP\n"
+ "100 / 1s0 HP\n"
+ "100 /10S hp\n"
+ "100/10S HP\n"
+ "100/10SHP\n"
+ "100/10SPS\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}