$re = '/[^/]+/([0-9 ]+).{2}/m';
$str = '2asd 100 ps
100 / 100 PS
100 / 100 HP
100 / 1s0 HP
100 /10S hp
100/10S HP
100/10SHP
100/10SPS
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);