const regex = /[^/]+/([0-9 ]+).{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\/]+\/([0-9 ]+).{2}', 'gm')
const str = `2asd 100 ps
100 / 100 PS
100 / 100 HP
100 / 1s0 HP
100 /10S hp
100/10S HP
100/10SHP
100/10SPS
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}