using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:a(?=a*(\1?+b)b*(\2?+c)))+\1\2$
";
string input = @"aaabbbccc
abc
ab
aaabbbcc
aaaabbbbcccc
aabbbb";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}