$re = '/^(?:a(?=a*(\1?+b)b*(\2?+c)))+\1\2$
/m';
$str = 'aaabbbccc
abc
ab
aaabbbcc
aaaabbbbcccc
aabbbb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);