re = /^(?:a(?=a*(\1?+b)b*(\2?+c)))+\1\2$
/m
str = 'aaabbbccc
abc
ab
aaabbbcc
aaaabbbbcccc
aabbbb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end