#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{\$[a-zA-Z0-9._+%]+\}"
Local $sString = "Obsahová symbolika" & @CRLF & _
"" & @CRLF & _
"{$nadpish21} - nadpis h1 - h6, 1 - 128" & @CRLF & _
"{$htmltext21} - html text 1 - 128" & @CRLF & _
"{$plaintext1} - čistý text 1 - 128" & @CRLF & _
"{$arturl} - url daného konkrétního článku" & @CRLF & _
"{$pageurl1} - url vybraného článku, 1 - 128"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")