const regex = /\{\$[a-zA-Z0-9._+%]+\}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\$[a-zA-Z0-9._+%]+\\}', '')
const str = `Obsahová symbolika
{\$nadpish21} - nadpis h1 - h6, 1 - 128
{\$htmltext21} - html text 1 - 128
{\$plaintext1} - čistý text 1 - 128
{\$arturl} - url daného konkrétního článku
{\$pageurl1} - url vybraného článku, 1 - 128`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}